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Quick guide valid only for Gen2 TCR cars, using TCR Marelli ECU: 
• CUPRA Leon Competición  
• Audi RS3 LMS TCR 
• CUPRA Leon VZ TCR  
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1. CAR DEVICES AND LAPTOP INTERFACES  
 

Car devices  
ECU MARELLI 

• License by VAG dongle, 
see parts catalogue  

ADU display 
• License free. SW available 

at the VAG mts platform  

GATEWAY UNIT 
• License temporary on 

demand 

 

 

 

 

 

GPS / Antenna 
• License free. SW available 

at the VAG mts platform 

  

 

  

 

Laptop Interface tool: 

CAN interface 

part nº: 5FR910336 

New Peak-Can interface / from 2024 onwards 

Catalogue part nº: 5FR910336A 

 

  
Ethernet cable  
(market std.) 
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2 PROGRAM FILES 
 
Where can you find all the files you may need? 
Find all necessary files into two .zip folders available at the online platform in the “PROJECTS & 
SOFTWARE” section. 

 

https://vwgroupmotorsport-onlineplatform.com 
 
 
What is included on this .zip files? 
 SW_INSTALLATION  

o Last version Firmware and Software for the devices installed into your car.  
 

 SW_PROJECTS  
o Last version of Projects and Configurations for the SW installed on your 

laptop/devices.  

 

IMPORTANT: The latest published versions usually correct errors or update the devices to comply 
with regulations updates. It’s highly recommended to maintain the racing car updated to last 
version.  
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3 ECU MARELLI  
 
There are two software from Marelli to manage ECU SRG-141 TCR, SYSMA and WINTAX. 

• SYSMA for Sysma Projects and Tables upload, communication in live as well as 
calibrations. 

• WINTAX for data acquisition download and analysis. 
 

Communication Line  
By default, ECU “project” is setup to communicate with ETHERNET LINE.  

To connect to the car, the Ethernet IP address should be fixed to 192.168.1.xxx (last three xxx 
values should be between 0 and 253) and the subnet mask 255.255.255.0 

 

 

How do you open a new Sysma Project? 
1. You need to find the directory of the SYSMA installation. Usually: C:\ Program Files \SYSMA 

2. Open the folder Projects and copy there the new SYSMA project previously uncompressed. 

3. Open SYSMA, go to FILE > OPEN PROJECT and choose from the list the new project 
version. 

           
 

Now, you are ready to update the ECU of the car. The next slides will explain how to do it. 
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ECU Firmware update                  
Follow the next steps to update the firmware: 

1. With the car completely off, connect the CAN/Peak-CAN interface to the Diagnostics 
connector. Make sure the interface switch is in ON position.  

 
2. Connect the ethernet cable between your laptop and the car. 

3. Turn on the car (12V). 

4. After 10s, check the app “Find Devs” if you detect the ECU with the alias “BOOT mode”.  

  

5. Open SYSMA 
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6. Double click on TCR.cdl 

7. Click Run 

 
8. Double click the device (IP) 

9. Wait until the process is finished. 

 
 

10. Close the window TCR.CDL 

11. Turn off the car (12V OFF) 

12. Move the switch toggle of the CAN/Peak-CAN interface cable to OFF position to exit the 
Boot mode. 

13. Repeat steps 6, 7, 8, 9 and 10 with the file fpga_141_conditional.cdl in these two following 
cases: 

o ECU is brand new (spare part) 
o ECU serial number from 500 onwards 

 

Note: If the fpga file is flashed out of these conditions, the process will be aborted because this 
additional process is not necessary.   
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ECU mapping & acquisition table update 
1. Turn on the car (12V ON) 

2. Inside the project there are two different calibration files (.CLX). According to the gearbox 
that is mounted on the car (Hewland or Sadev) you have to choose one or the other file. 

3. In Sysma, right click on “CU-EA888Evo4-C-H-S_x-x-x.clx” > Open CLX Management > 
Select the .clx file > click on Replace 

Hewland Gearbox       CU-EA888Evo4-C-H-S_x-x-x.clx 

Sadev Gearbox      CU-EA888Evo4-C-S-S_x-x-x.clx 

  
4. Then, double click on Control and Logging, then you will see the indicators becoming green. 

 
5. Right click on “CU-EA888Evo4-C-H-S_x-x-x.clx”   

6. Click on Write Calibrations  

7. To send the Acquisition table, right click on “VAG_TCR_14.X.X.X_CUPRA_V0x.TDX” or 
“VAG_TCR_14.X.X.X_AUDI_V0x.TDX”, according to the car brand 

  
8. Click on Transmit table. Make sure the alias is matching your car’s chassis number 

9. Power cycle the car before starting the engine (12V OFF  12V ON) 

IMPORTANT! Make sure the partial checksums you see in the “System” layout of SYSMA 
are the ones published in the last bulletin. 
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Now you have ECU software updated with the last engine map and acquisition table. 

 

Electrical calibrations (see User Manual Electric Electronics) 
IMPORTANT: Calibrations are necessary when Firmware has been changed.  

Every sensor of CUPRA/AUDI is calibrated and tested during the manufacturing process. However, 
if some components are replaced, a calibration is required. It consists in a quick process using 
SYSMA. 
 
These common steps must be followed to start the calibration: 

- Connect the Ethernet wire to the car and the computer. 
- Switch on the power supply (green button in the console). 
- Press the IGNITION button of the keypad. 
- Open SYSMA with the proper project loaded.  

 
A. Pedal Learning 
- Go to the “Learnings” tab. 

 

 

 

 

 

 

 

 

 

Do not press physically the pedal and select “min” in SYSMA. Then press the pedal 100% and 
select “max”. 
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B. Throttle autolearn 
- Go to the “Learnings” tab. 

 

 
- Select the learn option and press out of the violet rectangle to initiate the auto learn process. 

You will observe the throttle bars going from 0- 100% automatically. 

  

 

C. e-wastegate autolearn 
- Go to the “Learnings” tab 
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- Select the learn option and press out of the violet rectangle to initiate the auto learn process. 
You will observe the wastegate status going from 0- 100% automatically. 
 

 

 

IMPORTANT: After all the calibrations are done, the car must be completely power cycled (KL30). 
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4 LAUNCH ENGINE SPEED LIMITER CHOICE 
 

From now on (June 2024) there are only three launch speed limiters available: 4400, 4000 and 3600 rpm 
(default 4000rpm) 

To change between them, you must open the .clx file and look for the parameter Launch engine 
speed limiter choice. 

 

You can select Lim1, Lim2 or Lim WET which correspond to the three values mentioned above (4400, 4000 
and 3600 rpm).  

If at any time you would like to check the corresponding rpm limiter value table, you can open the 
parameter Launch engine speed limiter. 

Once you choose your preferred value, right click on the parameter, and click on Write selected calibration 
to send the value to the ECU.  

IMPORTANT:  It is not allowed to modify the provided values of the parameter Launch engine speed 
limiter, changing this table will change the checksum.  
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5 TYRE CIRCUMFERENCE CHOICE 
 

Due to the different tyres, with different diameters, used in TCR championships, we advise you to 
adjust the tyre circumference to match the wheel speeds and the GPS speed. This will improve the 
data analysis and will help the ECU to adjust better Pit and FCY limiters. 

To do it, you must open the .clx file and look for the parameter Tyre Circumference Type. 

The table below shows which value corresponds to each tyre manufacturer. Default value is 1 that 
corresponds to Kumho tyres.  

 

 

Once you choose your preferred value, right click on the parameter and click on Write selected calibration to 
send the value to the ECU.  
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6 ADU DISPLAY (advanced display unit) 
 

Find all information about how to operate with the configuration and layouts characteristics of the 
ADU in the “ADU_EcuMaster User Manual”, available on the platform.  

Two ADU display models are existing, 5 and 7 inch. Here below you will find a quick guide for 
installation and operations with the ADU device.  

 

SW Installation  
Using the files on the .zip folder downloaded, install in your laptop the ECUMaster ADU software 
like following:  

1. ADUSetup_72_0_VAGTCR.exe for 5” ADU  
2. ADUSetup_78_0_VAGTCR.exe for 5” & 7” ADU 

*Updated versions might be available on the VAG motorsport portal. 

 

How to connect the laptop to the ADU 
1. Use the CAN/Peak-CAN interface tools:  

a. USBtoCAN interface 

b. Laptop-tool + PEAK CAN interface: You must select the third position on the rotary 
switch (System cockpit Display). 

 
2. With the car completely off, connect the interface to the Diagnostic connector. 

 
3. Switch ON the car with the Main button (12V). 
4. Open EcuMaster ADU7 VAGTCR software and select one of the templates shown. 
5. If you want to open a different project, click on File > Open Project and select the desired 

one.  
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6. Once the Project file is open, click on File > Make Permanent. 
7. Disconnect the interface from the Diagnostic connector and make a power cycle.  

 

IMPORTANT: All processes explained in this technical note are also explained on the User manual 
Electric Electronics as well as in the Marelli Wintax or Sysma User Manual. Please, read and use 
them.  

 

7 GPS MODULE & ANTENNA 
 

There are two GPS antenna modules installed on the VAG TCR cars models: 

• GPStoCAN module for Audi RS3 LMS TCR and CUPRA 
LEON Competicion, corresponding to 5” display. 

• GPStoCAN_V2 module for all car models, including 
LEON VZ TCR, corresponding to 7” display. 

 

SW Installation  
Download and install the Software LightClientSetup_2_0.exe and gps2__fw4_0.bin file for any 
operation or update of the GPS module or antenna.  

 

GPS module update process 
1. Install LightClientSetup_2_0.exe in your computer. 

2. Connect the display CAN interface or the Peak Can Interface to the diagnostic connector 

and switch on Main Power supply. 

3. Open the LightClient Software and choose “auto” as CAN bit rate. 

4. In the Devices zone, choose the gps2 module. Double click on it.  

5. Click on the Upgrade button and select the file “gps2__fw4_0.bin” 

6. Wait until the firmware update is done. 

7. In the properties zone, activate the “High rate IMU output” square box. Then select the ID 

number 0x408 Standard on the “Output CAN ID”. 

8. On the IMU config box, select the orientation “Custom” and change the orientation of the 

three axis X (Back), Y (Left) and Z (Up).  

IMPORTANT: If a v1 GPS module (Audi RS3_LMS or CUPRA Leon Competición with 5” ADU 
display) is updated with this FW, the GPS may not work properly 
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(.3) LightClient Software and choose “auto” as CAN bit rate 

 
(.4,5,6,7,8) 

 

Wintax properties: 
After doing the GPS module FW update, a new FFT Low pass filter at 20Hz on the G_X, G_Y 
and G_Z channels must be activated on Wintax, as shown below on the Graph Properties 
window:  
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8 GATEWAY  
 
Gateway device has the function of router for the different CAN-BUS and LIN-BUS lines 
and in addition to controlling other series components such as car lights or wiper. 
 
This device does not usually have updates, but sometimes it does. For this reason, access 
to this component is temporary and through a license when this occurs. Below we explain 
the procedure to acquire the license and update the GTW SW. 
 
How to proceed with SW update on the Gateway.  
 

1. Download Ecotron_Gateway.zip folder from the Projects & Software folder at the Download 
Area on the Online Platform.  

2. Uncompress the zip folder. You will find three files inside (EcoFlash_setup.exe, 
PG_Default.dll and the .mot file that will be flashed) 

3. Install EcoFlash software on your PC using EcoFlash_setup.exe 
4. The first time EcoFlash is opened, you will need to upload the .dll file. Click on Help > 

SeedKey DLL and open the PG_Default.dll file. 
 

 
 
How to purchase and activate the SW license 
 

1. To purchase the EcoFlash license (PC based 1 month), you will need to contact Ecotron 
(USA) through the following email support@ecotron.ai. The license has a cost ($) and it will 
be active for 1 month since the moment it is given, so be sure you can have access to the 
car to be able to update the gateway. This cost could be updated yearly by Ecotron 
company. 

2. Ecotron will request your company data and your Key File.  
3. You can generate the Key File by going to Help > License Manager > Create Key File. 

IMPORTANT: provide the Key File of the specific computer you will use for EcoFlash. The 
licence will only work on that computer.  
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4. With this information, Ecotron will send you a proforma invoice to be paid and when they 
receive the payment, they will send you the License file to be registered on the License 
Manager, by selecting the .lic file after clicking on the Register License button. 
 

 
 
 
How you can use EcoFlash software to update your gateway: 
 
The process is simple, follow the next steps: 

1. Connect the PCAN-USB device with the Laptop Tool (CAN Interface). 
2. Connect the USB connector at the PCAN-USB to any USB port on the laptop and the 

Deutsch connector from the Laptop Tool to the car. 

 
 

3. Select the rotary switch on the Laptop Tool at the second position (GATEWAY) and check 
the Boot switch is not activated. 

    
4. Open the EcoFlash software, select Open Device and Open File (select the file .mot sent). 
5. The car must be completely powered off. 
6. Click flash on the program. 
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7. Immediately, push the ON button of the car and hold on (keep the finger pushing on the 
button during the flashing time) 

8. You will see a progress bar in EcoFlash. (approx. 2 minutes) 
9. Once it is finished successfully, you can release the ON button and the update process is 

finished. 
 

How to setup your car configuration: 
If the gateway will work on an Audi RS3 LMS TCR or a CUPRA Leon Competición, it is not 
needed to do any other action. It will automatically recognise the car and will adapt by itself. 
 
If the gateway will work on a CUPRA Leon VZ TCR, after finishing the flashing process, you have to 
press together and hold the rain lights and windscreen heater buttons and then click on Main OFF 
switch (marked in Red colour). Then, the electronics car setup will change. 
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